libgnutls28-dev_3.2.11-2_amd64.deb


Advertisement

Description

libgnutls28-dev - GNU TLS library - development files

Property Value
Distribution Mint Debian
Repository Mint Upstream amd64
Package name libgnutls28-dev
Package version 3.2.11
Package release 2
Package architecture amd64
Package type deb
Installed size 2.71 KB
Download size 606.29 KB
Official Mirror packages.linuxmint.com
GnuTLS is a portable library which implements the Transport Layer
Security (TLS 1.0, 1.1, 1.2) and Secure Sockets Layer (SSL) 3.0 and Datagram
Transport Layer Security (DTLS 1.0, 1.2) protocols.
GnuTLS features support for:
- TLS extensions: server name indication, max record size, opaque PRF
input, etc.
- authentication using the SRP protocol.
- authentication using both X.509 certificates and OpenPGP keys.
- TLS Pre-Shared-Keys (PSK) extension.
- Inner Application (TLS/IA) extension.
- X.509 and OpenPGP certificate handling.
- X.509 Proxy Certificates (RFC 3820).
- all the strong encryption algorithms (including SHA-256/384/512 and
Camellia (RFC 4132)).
This package contains the GnuTLS development files.

Alternatives

Package Version Architecture Repository
libgnutls28-dev_3.2.11-2_i386.deb 3.2.11 i386 Mint Upstream
libgnutls28-dev - - -

Requires

Name Value
libc-dev -
libc6-dev -
libgnutls-xssl0 = 3.2.11-2
libgnutls28 = 3.2.11-2
libgnutlsxx28 = 3.2.11-2
libp11-kit-dev >= 0.11
libtasn1-6-dev >= 3.1
nettle-dev >= 2.5
zlib1g-dev -

Provides

Name Value
gnutls-dev -

Conflicts

Name Value
gnutls-dev -

Obsoletes

Name Value
gnutls-dev -

Download

Type URL
Binary Package libgnutls28-dev_3.2.11-2_amd64.deb
Source Package gnutls28

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgnutls28-dev deb package:
    # sudo apt-get install libgnutls28-dev

See Also

Package Description
libgnutls28_3.2.11-2_amd64.deb GNU TLS library - main runtime library
libgnutlsxx27_2.12.23-13_amd64.deb GNU TLS library - C++ runtime library
libgnutlsxx28_3.2.11-2_amd64.deb GNU TLS library - C++ runtime library
libgudev-1.0-0_204-5linuxmint1_amd64.deb GObject-based wrapper library for libudev
libgudev-1.0-dev_204-5linuxmint1_amd64.deb libgudev-1.0 development files
libopus-dev_1.1~beta-3mint1_amd64.deb Opus codec library development files
libopus-doc_1.1~beta-3mint1_all.deb libopus API documentation
libopus0_1.1~beta-3mint1_amd64.deb Opus codec runtime library
libpam-systemd_204-5linuxmint1_amd64.deb system and service manager - PAM module
libssl-dev_1.0.1j-1_amd64.deb Secure Sockets Layer toolkit - development files
libssl-doc_1.0.1j-1_all.deb Secure Sockets Layer toolkit - development documentation
libssl1.0.0_1.0.1j-1_amd64.deb Secure Sockets Layer toolkit - shared libraries
libsystemd-daemon-dev_204-5linuxmint1_amd64.deb systemd utility library - development files
libsystemd-daemon0_204-5linuxmint1_amd64.deb systemd utility library
libsystemd-id128-0_204-5linuxmint1_amd64.deb systemd 128 bit ID utility library
Advertisement
Advertisement